Otro script para cacti. Contando el número de conexiones CVS

Acabo de crearme un pequeño script para Cacti para contar el número de sesiones CVS establecidas en un momento determinado.

El script es muy simplón y realmente habría mejores formas de hacerlo, pero el caso es que necesitaba contar el número de sesiones CVS y hacerlo con un shell script no me ha llevado más de 2 minutos.

#!/bin/sh
#
# File     : CountCVSConnections.sh
# Version  : 1.0
# Date     : November 22th 2007
# Author   : Jorge Tomé Hernando <jorge@jorgetome.info>
#
# Description
# ===========
#
# Connect to a host via SNMP and count the number
# of TCP sessions in state "established" over the
# 2401 port.
#
# Usage
# =====
# CountCVSConnections [COMMUNITY] [HOST]</pre>
<pre>snmpwalk -Os -c $1 -v 1 $2 .1.3.6.1.2.1.6.13.1.1 | \\  # Get the full list of TCP connections
grep -e ".2401..*established" | \\      # Filter the established connections over 2401 port (CVS)
wc -l | \\      # Count the number of connections
awk '{printf "Active CVS connections: " int($1)}'     # Print the result

Google Desktop disponible para Linux

Acabo de leer en Lifehacker que Google Desktop está disponible para Linux.

Google Desktop es una aplicación que he echado de menos desde que hace ya más de 6 meses me pasé definitivamente en el trabajo a Ubuntu. Desde entonces solo he arrancado MS Windows XP en una o dos ocasiones.

Ubuntu incluye Beagle al que, he de ser sincero, no he dado muchas oportunidades. No recuerdo haberlo usado nunca y cuando he visto cómo se usa no me parece tan sencillo y potente como Google Desktop. Además cuando monitorizo cómo se está utilizando la CPU de mi portátil Beagle siempre aparece muy arriba en la lista.

Voy a bajarme Google Desktop para Linux y darle una oportunidad, a poco bien que lo haga sustituirá a Beagle en mi escritorio. Ya os contaré.

Actualización. Ya me lo he bajado e instalado y ya está funcionando en mi escritorio. La instalación (me he bajado el deb) no ha supuesto ningún problema e inmediatamente tenía disponible en la barra de menú el icono de Google Desktop. Igual que en MS Windows pulsando dos veces la tecla Ctrl aparece el cuadro de búsqueda.

Los usuarios (de Dell) quieren Linux preinstalado en sus portátiles

Leo en Slashdot que Dell ha abierto un website en el que recoger las sugerencias de sus clientes y, ¡sorpresa!, la petición más numerosa por un margen de casi 2 a 1 es que los usuarios de Dell quieren poder pedir sus portátiles con Linux preinstalado.

¿Sorpresa?. Quizás si lo pensamos un poco no debería sorprender tanto. No estoy pensando en que todos esos usuarios tengan como objetivo tener Linux en sus portátiles, sino más bien dejar de pagar el «canón» de la licencia del sistema operativo de Microsoft.

En mi caso hace una semana que me han cambiado el portátil de trabajo que tenía, un HP Compaq nx6125, por un nuevo y flamante Dell Latitude D520 en el que Ubuntu 6.10 funciona como un cañón y sin ningún problema irresoluble.

¡Upps!, mi portátil no puede ejecutar MS Windows Vista

Acabo de ejecutar el test que ha desarrollado CNET conjuntamente con System Requirements Lab y que evalua si tu ordenador tiene o no capacidad para ejecutar MS Windows Vista.

El resultado ha sido el siguiente:

graph_all_2_opt.gif

Como veis mi portátil no alcanza los requerimientos mínimos ni para ejecutar la versión Basic del nuevo sistema operativo de Microsoft. ¡¡Qué pena!!, voy a tener que pedirles a mis jefes que me lo actualicen a uno que pueda ejecutar al menos el nivel «MAINSTREAM». Wink

Concretamente el problema que me impide alcanzar al menos el nivel «BASIC» es la tarjeta gráfica. Mi portátil monta una ATI Mobility Radeon Xpress 300 que parece que está bastante lejos del nivel mínimo recomendado.

Para que os hagáis una idea la configuración de mi portátil es la siguiente:

  • Procesador AMD Turion 64 Mobile ML-28 a 1.60 GHz
  • 1,12 GB de memoria RAM
  • 60 GB de disco duro
  • Tarjeta gráfica ATI Mobility Radeon X300

Según CNET para poder ejecutar MS Windows Vista a nivel BASIC tendría que actualizar mi tarjeta gráfico (algo imposible por otro lado). Para poder ejecutar el nivel MAINSTREAM tendría que cambiar la tarjeta gráfica, el procesador e incrementar la memoria hasta 2 GB al menos.

Estoy muy apenado. 😀

Solo para compensar os diré que la semana pasada instalé en este incompetente portátil el gestor de ventanas Beryl sobre mi Kubuntu y os puedo decir que, sin tirar cohetes, todo funcionó razonablemente bien incluidos todos los efectos inútiles pero espectaculares de Beryl. En la red podréis encontrar cientos de vídeos ilustrando el funcionamiento de Beryl.

Por cierto, al test he llegado a través de una noticia de Xataka.