VMware Converter 4, pesadillas.

Solo una nota rápida acerca de VMware Converter 4.

VMware Converter es una herramienta gratuita de VMware que nos permite convertir máquinas virtuales de unos formatos a otros. Es muy útil en entornos mixtos en los que tienes máquinas en distintos formatos: VMware Server 1.x, VMware Server 2.x, VMware ESX, etc..

Yo ya lo había utilizado en alguna ocasión y había funcionado sin problemas, ahora viene la pesadilla…

Hace unas semanas recibí un disco duro externo que contenía unas máquinas virtuales en formato OVF, después de descubrir qué era el dichoso formato me bajé la última versión del VMware Converter, la 4.0.1, para convertir las máquinas en cuestión a formato VMware Server 1.x, que es el  que utilizamos en nuestros servidores.

Las máquinas eran grandes (relativamente), desde los 40 GB a los 150 GB. No disponía de dicho espacio libre en ninguno de mis ordenadores así que pensé convertir las máquinas desde el disco duro externo en las que las tenía (de 2 TB de tamaño) hacia el mismo disco duro externo ya que tenía más de 1 TB de espacio disponible, vamos, que por espacio no será 🙂

Bueno, pues el amigo VMware Converter se empeñaba en decirme que no disponía de espacio suficiente para realizar la conversión. Probé todo lo que se me ocurrió, incluso a cambiar el punto de montaje del disco duro externo ya que contenía un espacio en el nombre y pensé que sería la típica situación en la que el software no “digiere” correctamente ubicaciones con espacios en el nombre. No funcionó.

Lo probé en distintos ordenadores, en distintos sistemas operativos (MS Windows XP Profesional, Ubuntu), con distintas combinaciones de discos (por si acaso al VMware Converter no le gustaba que el origen y el destino estuviesen en un disco externo). No funcionó nada.

En una de las muchas búsquedas  que hice en Google al respecto llegué al blog de Shan Wildermuth en el que hay un artículo comentando distintos problemas que él también ha sufrido con VMware Converter y uno de  ellos el mismo que estaba sufriendo yo. ¡¡Aleluya!!, ¡¡también explicaba el motivo y la solución!!

Bueno, pues en un alarde de calidad en la programación, resulta que el VMware Converter utiliza como directorio temporal para las tareas de conversión, no el directorio temporal que todos los sistemas operativos asignan a los usuarios, sino el directorio desde el que arrancas el puñetero VMware Converter.

Claro, en todas mis pruebas había lanzado el VMware Converter desde el menú, es decir, desde el directorio en el que está instalado el programa, que, para más INRI, en todos los equipos en los que había hecho pruebas no disponía del espacio suficiente (más de 30 GB) para que el VMware Converter pudiera realizar la conversión.

Solución, abrir una consola de comandos, situarse en un disco/directorio en el que haya suficiente espacio libre (yo me ubiqué en el disco duro externo) y desde ahí lanzar el programa. Problema resuelto.

Si a alguno le pilla cerca el programador responsable de tal desaguisado que le de un cate de mi parte 🙂

O a su superior que no le dio el tiempo suficiente para probar en condiciones el programa 😉

Instalando VMware Server 1.0.8 y VMware MUI 1.0.8 en Ubuntu 8.0.4 Server

Ando estos días instalando nuestro cuarto servidor dedicado a la virtualización de entornos.

En este caso me he decantado por Ubuntu 8.0.4 Server y VMware Server 1.0.8 (he probado la 2.0.0 y no me convence todavía, sobre todo porque los otros tres servidores siguen en la 1.0 de VMware).

La instalación del VMware Server sobre Ubuntu no ha tenido absolutamente ningún problema, pero la instalación del interfase web (VMware-MUI 1.0.8) me ha dado algunos quebraderos de cabeza que he resuelto con la información contenida en esta página.

El problema era que al ejecutar la instalación del VMware-MUI se quejaba diciendo que el VMware Server no estaba instalado

VMware Server must be installed on this machine for the VMware Management Interface to work

Básicamente la resolución del problema ha pasado por instalar una librería que faltaba:

jtome@aquiles:~$ sudo aptitude install libxi6

Con esto he podido finalizar la instalación del VMware-MUI sin problemas. Pero me encontré que el script de arranque del interfase web no funcionaba. En la misma página venía la solución, parchear el script.

jtome@aquiles:~$ cd /tmp
jtome@aquiles:/tmp$ wget http://users.piuha.net/martti/comp/ubuntu/en/httpd.vmware.diff
jtome@aquiles:/tmp$ cd /
jtome@aquiles:/$ sudo patch -b -p0 < /tmp/httpd.vmware.diff